locked Re: Important Announcement : The next release of JTAlert requires the .NET 5 desktop runtime


HamApps Support (VK3AMA)
 

On 7/04/2021 1:43 pm, Joe - W9RF via groups.io wrote:
I certainly hope these new changes do not require Windows 10?

AND why did I not receive an email about the changes?

Laurie VK3AMA  was the original email posted here on HamApps.groups.io?


W9RF - Joe

I never email people about future changes to JTAlert, apart from the Test team.

Sometimes I will drop hints, in this group, about upcoming new features, changes or fixes.

I don't normally publish the release notes for a new release ahead of time. Today's announcement of the NET5 requirement and publishing of the release notes was done due to the large amount of changes and to give people a chance to install the NET5 runtime ahead of time.

If you're still using Win 7 (why?) and don't have Extended Security Updates installed then you're likely out of luck and will have to stay with JTAlert 2.16.17. Info on getting Extended Security Updates for Win7 can be found here...

https://docs.microsoft.com/troubleshoot/windows-client/windows-7-eos-faq/windows-7-extended-security-updates-faq.

The list of .NET 5 supported Operating Systems can be found here...
https://github.com/dotnet/core/blob/main/release-notes/5.0/5.0-supported-os.md

The NET 5 requirement for JTAlert 2.50.0 and all future versions is a done deal, there is no going back. There is a lot of new code that is dependent on NET 5 functionality.


de Laurie VK3AMA


Join Support@HamApps.groups.io to automatically receive all group messages.