locked Re: Non-coloring of WSJT-X 2.2.0 -rc decodes by JTAlert - cause identified.


Norbert Graf - DD3KF
 

Hello Laurie,

 

yesterday I made another odd observation:

 

I decoded stations from a NEW GRID calling CQ:

 

JTALERT:

- Showing DXl with green background for CQ,

- only Audio Alert for NEW GRID,

- TX1 by DX showing light blue background for NEW GRID.

(sorry, no screen shot).

 

WSJT-X RC

pse see sample screen shot.

DX: DL3TW

 

My working environment:

- Windows 10, 64 bit

- WSJT-X 2.2.0 RC3 64 bit

- JTAlert 2.16.6

- HRD Log 6.7.0.277, logging via JTAlert

Alter priority:

- NEW GRID

- CQ

 

I dont know if this is related to your following post.

 

73!

 

______________

Norbert Graf

D D 3 K F

 

Von: Support@HamApps.groups.io <Support@HamApps.groups.io> Im Auftrag von HamApps Support (VK3AMA)
Gesendet: Dienstag, 2. Juni 2020 00:42
An: Support@HamApps.groups.io
Cc: main@HamAppsBeta.groups.io
Betreff: [HamApps] Non-coloring of WSJT-X 2.2.0 -rc decodes by JTAlert - cause identified.

 

I finally tracked down the JTAlert non-coloring of decodes in the release candidates.
WSJT-X2.1.2 works correctly, but the -rcs don't when the decode string contains a positive report. Reports that are negative are colored correctly. Tested both rc2 & rc3

eg.

"AA1AA VK3AMA +12" & "AA1AA VK3AMA R+12" - FAIL

"AA1AA VK3AMA -12" & "AA1AA VK3AMA R-12" - OK

JTAlert sending the coloring command containing the "VK3AMA R-12" string correctly colors while "VK3AMA R+12" fails with the only difference is the number sign in the string sent to WSJT-X.

This report has already been sent to the WSJT-X dev-list.

de Laurie VK3AMA

Join Support@HamApps.groups.io to automatically receive all group messages.