locked Re: V2.15.2 looses audio alerts


John Petrocelli
 

Hello,

  As Laurie has said, this was released wit some limited testing.

   It works here very well (Running Win 7 64bit).

   The only "kink" I see is that sometimes when I restart the system, there will be no audio.  I simply, select the "Other" audio device (Not same sound device as radio !) and then close and restart JTAlert.  This works every time.
    I seem to need to switch back and forth from "Default Sound Device"  from/to "USB Audio".

    As a rule now, I ALWAYS do a "Test Sound Card" from the Settings drop down when I start JTAlert.  BTW, I have a monitor with internal speakers so that is the "Other" audio device that I mention.


Thanks again Laurie for all your GREAT work !!
John - WA2HIP
John R. Petrocelli - WA2HIP
¶¶¶¶¶¶¶¶¶¶
Primary Home Page:
   http://wa2hip.com
On 11/14/2019 9:16 PM, HamApps Support (VK3AMA) wrote:

On 15/11/2019 7:53 am, Mike Horn wrote:
I lost my audio alerts as well with version2.15.2.  I tried everything in the book; Windows audio settings, JTAlert settings, program start/restart, etc....but no dice.
Finally gave up and reverted to version2.15.1 and everything works fine.  I saw another post where someone used a software to reload his previous
Windows settings but does not specify what values changed (for those of us who do not utilize that software).  I have had no problems in the life of JTAlert
when upgrading so this has me baffled. I assume that the reversion indicates a changed Windows setting.  Hopefully someone will be able to identify the problem
so we can get back to upgrading.
Also, a heartfelt thanks to all those involved in the development of this fun software.
Mike N8FRI
Mike,

2.15.2 introduced a new audio library into the code. This was a rapid change (minimal testing) due to the excessive audio delays experienced by Flex users (5, 10 & 30 seconds) with 2.15.1. The new 2.15.2 library resolved the audio delay issues, but brought with it several bugs that have come to light since its introduction. Apparent non playing of audio is one of them. A new build of JTAlert that replaces this hastily added audio library is currently with the Test team. Check you email, I have sent you direct a link to the latest build, please test and report back.

de Laurie VK3AMA



Join Support@HamApps.groups.io to automatically receive all group messages.