locked Re: JTAlert-X won't send QSO's to HRD anymore


Dave Garber
 

Are you running wsjt in usb.   Or usb data?


On Thu, Aug 2, 2018, 4:43 PM Robert, <Robert@...> wrote:
Hi Dave,
I recently switched over to the SignaLink due to too many issues with the KW soundcard, WinOS, etc.

On the rear of the 590S, HRD said I need the Kenwood USB to computer COM cable for HRD to work.  Done.   HRD works fine.

The KW ACC2 Port, normally used for Data Communications, is once again hooked to the SignaLink on one side, the outgoing side goes to the other Com port on the computer.  the KW Menu #63 is set for ACC2, for Data Communications.

The DB9 Serial connector is connected to my SteppIR antenna, SDA 100 Controller.

Everything is set for 9600 Baud, because that's what the SteppIR requires.   Before the SignaLink, when I was running WSJT & JTAlert-X, if I made a band change in WSJT, the radio would switch to that frequency, and so would the antenna.


Now, when I'm running the DM-780 program, that's the way it works with the SignaLink installed.  Perfect.  When I switch bands, radio and antenna follows.
Can't do the same thing using WSJT however.
If I make a Radio change, WSJT will follow.
But WSJT can't initiate a change anymore without Cat control.

I know it's a setting somehow in WSJT, but neither I nor HRD can find it.

Thanks,

Robert AC2MM


On 8/1/2018 9:18 PM, Dave Garber wrote:
I have hrd on a ts590sg, with cat , if I can help.  you must have the db9 connection on the back, while the signalink should be set to vox, for ptt.  do you have the serial port via a usb adapter??

need more info on how you expect cat...  not via the signalink usb


Dave Garber
VE3WEJ / VE3IE

On Wed, Aug 1, 2018 at 9:16 PM, Robert <Robert@...> wrote:
de Laurie,
Oops, I know you didn't see my latest post because I asked the Moderator to pull the post itself.  I got it working again, most likely due to a reboot, but it's sending logs normally now again to HRD.  Sorry about that miscommunication.

Thanks,

Robert AC2MM


On 8/1/2018 9:09 PM, Robert wrote:
de Laurie,
If you saw my latest post, the JTAlert-X/Logging issue is resolved.
The CAT issue remains the final problem I need help with.

Thanks,

Robert AC2MM


On 8/1/2018 9:03 PM, HamApps Support (VK3AMA) wrote:
Robert,

So much going on in your description.

Does the SignalLink support CAT control?
I suggest, you get WSJT-X HRD Cat Control working first, then move onto Getting JTAlert Logging working.

de Laurie VK3AMA

On 2/08/2018 10:03 AM, Robert wrote:
This is one of those issue where you don't know who to ask because there are several things in play here.

My understanding of JTAlert-X is that it is responsible for looking up the QSO info on QRZ.com, and installing the name and such to the completed QSO from WSJT, and sending it on it's way to the HRD Logbook, "My Logbook".
While I have been using this successfully for about a year now with no problems with my Kenwood TS-590S and HRD, I had to install a SignaLink sound card for other reasons.  I don't use the Kenwood internal soundcard anymore.

Rather than get Carpel Tunnel from retyping everything, let me paste my question I posted recently to the WSJT Users Group.
Please understand that the most important part of these two problems (for me) is to get JTAlert-X to send a completed QSO to the HRD Logbook.   That's why I'm here.

I'm having a problem setting up WSJT-X (1.9.1) / JTAlertX  to work with
HRD like it used to.
To simplify digital mode control, I eliminated using the Kenwood TS-590S
sound card, and reinstalled my SignaLink sound card instead. HRD helped
me with the setup and the DM-780 is working fine for all digital modes,
logging included.

WSJT / JTAlertX used to work perfectly with HRD before this point also,
logging all my contacts from WSJT/JTAlertX into HRD, changing the radio
frequency as I switched WSJT to different bands/modes, etc. Perfect.

Two problems:  (HRD running as normal)
1.  I have no CAT control.  I can't change bands, in fact the bands
window doesn't show you what band you are on.  Before using the
SignaLink, I would simply change to another band/frequency using the
dropdown box, then the radio would change to that band/frequency, as
well as the SteppIR antenna.
It transmits fine, receives fine, and the Power and Receive levels are
controlled via the SignaLink as they should be now.  Strangely enough,
if I change the band on the radio, WSJT will follow suit, but the
dropdown box will not work that shows you what frequency you should be on.

2.  It logs the QSO's into the WSJT ADIF file, but JTAlertX does not
transfer the completed QSO into HRD anymore.

Here is my setup as best i can describe it.

HRD for software.
Kenwood TS-590S
SignaLink sound card.
Win10 OS.

Kenwood TS-590S, Menu #63 Set to ACC2 port for Data Communication.
One cable from the Kenwood ACC2 Port into the SignaLink USB port, then
the outgoing SignaLink port (Radio) going to USB #5 Codec in the computer.
One cable from the Kenwood USB port direct to the USB #8 Codec in the
computer. (for HRD control)

WSJT Settings

Tab "Radio"
Rig:  Kenwood TS-590S
Left Pane:  COM 4   (USB #5 Codec), Eight, two, Hardware
Right Pane:   CAT, Rear Data, USB, None

Tab "Audio"
Audio:   Both Input & Output  (5-USB Audio Codec)

JTAlertX Settings

Enable HRD V5/VB6 Logging, Checked
Settings / HRD V5/V6 / PC IPv4 Address  127.0.0.1
Settings / Sound Card / [3] Speakers / headphones (Realtek) (This
enables JTAlertX to announce the wanted Countries, etc through the
stereo speaker system)

That's everything I can think of to describe my situation.
I had a previous WSJT situation which I won't go into now because adding
the SignaLink cured that problem. (as well as some others)

So the current status is that WSJT and JTAlert-X is working as it's own entity.
1.  JTAletrs-X won't send completed logs to HRD.
2.  I have no CAT control using WSJT.

These are probably related, I don't know, but I'm looking for help from wherever I can get it.

Thanks in advance,
Robert  AC2MM














Join Support@HamApps.groups.io to automatically receive all group messages.