locked Re: Reading Settings Data Stand-by just sits then not responding


HamApps Support (VK3AMA)
 

On 25/03/2018 12:00 PM, Mike Wolthuis wrote:
I have been running JT Alert just fine for 6 weeks, suddenly out of the blue, it stopped running, locked up.  I killed it with task manager, restarted the computer, will not come back up.  Just goes to Not Responding.  I tried uninstall all HamApps programs, I reinstalled them all, still same thing.

It's like the settings file is corrupt or something, is there a way to remove it and start fresh?

Mike
kb8zgl
Mike,

This is a new reported behaviour. The usual symptoms of a corrupt config file is that setting changes are not restored across JTAlert restarts. Perhaps your virus protection is interfering.

If it is a corrupt config, try the following...
  1. Stop JTAlert
  2. Use Windows File Explorer and navigate to the following directory...
    %localappdata%\HamApps\KD8ZGL\config\JTAlertX\
  3. You will see several files with a utc data/time as part of the filename. These are the backups and the data/time reflects when they were created.
  4. Delete the config.sqlite file.
  5. Rename one of the backup files to config.sqlite, choose a file that was created prior to you experiencing the Settings save problem.
  6. Start JTAlert and open the Settings and make a simple change.
  7. Close the Settings and JTAlert.
  8. Start JTAlert and open the Settings and check if the change made in step 6 is still set.
  9. If the change wasn't remembered, repeat steps 4 to 8, using an older backup.
  10. If none of the backups correct the problem, then the only option is to delete the config.sqlite file and start JTAlert without that file. It will be automatically created and you will need to re-enter your Settings and run a Scan Log to update your Wanted Lists.
Let me know how you get on.

de Laurie VK3AMA
   
 

Join Support@HamApps.groups.io to automatically receive all group messages.